Libertonia
Portada · Todo · Software Libre · Desarrolladores · Comunidad · Internet · Tecnología · Meta · Diarios
Sofware (no) libre en la Universidad... juas

MiKatp's Diary
Por MiKatp
departamento QuesecueeegueQuesecuellllgue , Sección Diarios
Puesto a las Sat Nov 29th, 2003 at 07:15:59 PM CET
El martes fue un día para recordar... bueno, mejor diré de los que no se olvidan. Todo empezó un viernes, esta es otra de esas críticas a windows de las que estais hartos de leer.

 



La clase acabó a su hora, todo el resto de la mañana del viernes libre. Al cabar la clase el profesor pregunta si alguien quiere pringar. Bueno, lo confieso, más bien nos ofrecimos solitos; había que demostrar que los dos ordenadores con linux del aula (ver el artículo "La intención es lo que cuenta") podían hacer las mismas funciones que los que tienen win.
En resumen, instalar R en una RedHat (R es un programa de estadística):

- ¿Quiere que instalemos R?
- Si no os importa además mirais porqué no coge la red este de aquí. Y si eso echadle un ojo a este que no lee del CDROM (con win).

Vaya, eso último no me lo esperaba, pero en fin. Empiezo por instalar R mientras el otro muchacho va ocupandose del win. Apt-get... ah, no, que es RedHat. Venga localizo CRAN, bajo el archivo, (como las balas, qué envidia de internet). Veamos como era... ah, sí: dpkg, esto... rpm -i blabla, fallo de dependencias.

Ingenuo de mi ¿qué esperaba?. A ver cómo se instala el paquete desde los cds. Vale entro en el menu de instalar programas y ahí no aparece esa librería (la tk creo que era). Hmm, igual no viene. Voy a ver qué versión, las dependencias las pone en un fichero README en la web, lo abro y dice: "La última columna es el número de CD, no recomendamos usar el instalador de RedHat porque es una patata" no textualmente, pero parecido. Mola, voy a por el CD 3 y lo instalo, entra sin problemas.

Ya he instalado el R, voy a intentar instalarlo en el otro Pc con linux pero falla la red. Ah sí, a este había que ver porqué fallaba. Veamos: netstat -r a ver la tabla de enrutamiento... hombre, alguien no sabía la diferencia entre gateway y dns, y no sé cómo enruta un servidor dns pero me da que no muy bien.
Intercambio las IPs, reinicio la red, correcto. Bajo el paquete de R, instalo la dependencia y fuera. Acabamos con linux. Tiempo transcurrido media hora.



Vamos con ese win que no lee el CD. Probamos, y efectivamente no lee el CD :) probemos con otro CD... vale, no es del CD (siempre hay que asegurarse). Abrimos otro PC del que sabemos que va el lector, intercambio y tampoco lee, debe ser fallo de la placa, esto ya es para el servicio técnico.

Probamos el lector en otra placa y esta vez sí va: confirmado, es cosa de placa o de la configuración de win. Nos volvemos locos mirando todas la opciones que tiene win para la configuración de un CD ATAPI (que son 3 casillas) y no vemos nada raro. Optamos por cambiar de torre, ya que había una que no se usaba y en esa sí iba. Todo de maravilla.

La montamos, la cerramos y la atornillamos. Encendemos y funciona chachi. Vamos a enganchar la red, ups... ¿y la tarjeta? No tiene tarjeta de red. Bueno, no pasa nada le ponemos la otra que iba perfecta. Se la ponemos y suturamos. El paciente despierta y está consciente, puede leer el CD y la operación ha sido un éxito. Recogemos y nos vamos.


Al dia siguiente vemos como el ordenador reparado no carga la GUI. Al pobre que lo intenta usar le toca reiniciar en modo prueba de fallos. Ahí arranca bien.

Por si fuera poco otro de los ordenadores reinicia sólo: es meter el login y reinicar. Y en los que tienen linux no se sienta nadie. Miro el que reinicia, voy a registro a ver si es de un virus, a ver... runservices, run, está en orden. Arranco de nuevo, ya no reinicia. Qué cosas. Voy a entrar en internet... "este equipo no tiene conexión y bla bla bla...". ¿Cómo que no? Veamos panel de control -> sistema: veo un dispositivo no reconocido, a ver de qué se trata "PCI ethernet controller" sí, me suena. Eliminar dispositivo, actualizar... clinck, AMIBIOS version nosequé. En fin, que no sé proqué reinicia y no tengo ganas de averiguarlo.

Media hora después alguien tiene cara de poquer: no detecta los discos duros al arrancar, nada de nada, ahora ni arranca.


En fin, parece una buena oportunidad para linux.

Por cierto, más acerca del soft libre, estoy montando (aprendiendo a montar) un cluster con Debian, y MPI en el departamento, corriendo NFS y NIS, ya os contaré.


Fue una pena no poder estar en en Córdoba justo el día 28, en fin, este fin de semana tocaba venirse al pueblo para dar el coñazo por libertonia. Otro dia nos veremos, no sabía que había de eso en Córdoba.
< hipergate: suite GPL de CRM, e-Marketing, Intranet y WebBuilding (6 comments) | Irate, decide que música te gusta (7 comments) >
Enlaces Relacionados
· More on MiKatp's Diary
· Also by MiKatp

Encuesta
Porqué reiniciaba el de win
· Estaba poseido 20%
· Recibia ordenes de MS 10%
· Sólo hacía lo contrario a lo que yo quería 40%
· Estaba viejo y cansado 20%
· Necesita a la rubia 10%

Votos: 10
Resultados | Otras Encuestas

Menu
· crear cuenta
· FAQ
· búsqueda
· Fuentes de Noticias

Login
Nueva cuenta
Usuario:
Contraseña:

Ver: Modo: Orden:
Sofware (no) libre en la Universidad... juas | 3 comentarios (3 temáticos, editoriales, 0 ocultos)
Problema de hardware (none / 0) (#1)
por musg0 a las Sat Nov 29th, 2003 at 08:32:58 PM CET
(Información Usuario) http://helvete.escomposlinux.org

Más que problema de Windows para mí que es un problema de hardware. Un equipo mal refrigerado o un bloque de memoria estropeado y ocurren las cosas más extrañas en los equipos.

Gran parte de los cuelgues de W9x eran debidos a hardware en mal estado (Cada día que pasa el hardware que venden es peor), pero como de normal también se colgaba la gente decía siempre que era cosa de windows cuando en muchos casos no lo era.

Pero hoy tengo una anécdota de WinXP que es para cagalse. Me traen un ordenador en el que no funciona el modem. En el listado de hardware sale el modem con una exclamación. Borro el iconito y reinicio (más que nada por vicios del pasado, porque no hace falta reiniciar). Me detecta el modem, me dice que seleccione el driver, lo pongo y listo. Ahora sí.

El que me lo ha traido jura y perjura que él a hecho lo mismo que yo.

Pero... me doy cuenta de que no pilla la tarjeta de red que está instalada. Como en windows no dice nada de la marca cojo knoppix y veo que es la típica Realtek 8139c. En windows no la pilla ni de coña aunque tiene un driver estándar para Realtek 8139c.

Abro el equipo, busco algo que me indique la marca y veo SMC1233. Bajo los drivers y tampoco me los coje. Pero... al rato me doy cuenta de que milagrosamente me la ha detectado y configurado como Realtek 8139c estándar. Yo flipo pero funciona.

Para que luego digan que Windows no es de juguete. Tanto el modem como la tarjeta de red se han instalado como mágicamente. Sin ninguna lógica aparente. Eso no lo hace un sistema profesional.



Para problemas de hard simpáticos... (none / 0) (#2)
por javiernoval a las Sun Nov 30th, 2003 at 02:28:57 PM CET
(Información Usuario)

... los que da el ordenador de mi hermana, un portatil Airis comprado recientemente. El XP Home que traía preinstalado jura y perjura que hay un disco extraíble conectado al puerto USB, y por más que le des al extraer, te cargues el dispositivo o lo que sea, el condenado vuelve a aparecer en el siguiente arranque. ¿Alguna idea?

[ Padre ]


 
YPMQ Hardware (none / 0) (#3)
por sinner a las Mon Dec 1st, 2003 at 06:12:08 AM CET
(Información Usuario) http://www.escomposlinux.org/sinner/

y aún diría más: los capacitadores[*] de ese PC (casi seguro un Pentium-III o Celeron de la época) están fallando.

¿te sena el tema de los capacitadores que explotaqban/perdían líquido? Pues eso.

O bien cambias los capacitadores via una operación delicada o bien cambias la placa base.

[*] ¿capacitadores? ¿condensadores? ¿$OTRA_COSA? alguna cosa de estas. QUe me parece a mi que ya llevo demasiados años en gringolandia y ya no se hablar castellano



Salut,
Sinner


--
Sinner from the Prairy
Pogüered bai Mandrake
BOFHers Syndicate http://bofhers.org


 
Sofware (no) libre en la Universidad... juas | 3 comentarios (3 temáticos, editoriales, 0 ocultos)
Ver: Modo: Orden:

ecol Logo Powered by Scoop
Todas las Marcas Registradas y copyrights de esta página son propiedad de sus respectivos dueños.
Los comentarios son propiedad del que los escribe.
Los iconos de las noticias y el logotipo son propiedad de Javier Malonda.
El Resto © 2002 Escomposlinux.org y aledaños.

Puedes sindicar los contenidos de libertonia en formato RSS 1.0 y RDF 0.9. También se puede sindicar la cola de envíos pendientes de moderación.

El proyecto escomposlinux.org está dedicado a la memoria de tas

crear cuenta | faq | búsqueda